summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2012-01-15 10:04:58 -0500
committerMatt Turner <mattst88@gmail.com>2012-01-20 15:54:08 -0500
commitb38d7a0a248c2a3ad227cb5d21c1c95a6519e4ae (patch)
tree89533ac3df4f42d8a26291236a4176c0c92ac81c /configure.ac
parente0ee818e2f24f3d9604c04df4a056798bccc48ec (diff)
automake: src/mesa/drivers/dri/r200
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 6 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index c0bdacbd61..95990016b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1272,7 +1272,7 @@ case $DRI_DIRS in
esac
case $DRI_DIRS in
-*radeon*)
+*radeon*|*r200*)
PKG_CHECK_MODULES([RADEON], [libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
for d in $(echo $DRI_DIRS | sed 's/,/ /g'); do
@@ -1280,6 +1280,9 @@ case $DRI_DIRS in
radeon)
HAVE_RADEON_DRI=yes;
;;
+ r200)
+ HAVE_R200_DRI=yes;
+ ;;
esac
done
@@ -1288,6 +1291,7 @@ esac
AM_CONDITIONAL(HAVE_I915_DRI, test x$HAVE_I915_DRI = xyes)
AM_CONDITIONAL(HAVE_I965_DRI, test x$HAVE_I965_DRI = xyes)
+AM_CONDITIONAL(HAVE_R200_DRI, test x$HAVE_R200_DRI = xyes)
AM_CONDITIONAL(HAVE_RADEON_DRI, test x$HAVE_RADEON_DRI = xyes)
case $DRI_DIRS in
@@ -1296,13 +1300,6 @@ case $DRI_DIRS in
;;
esac
-case $DRI_DIRS in
-*r200*)
- PKG_CHECK_MODULES([RADEON], [libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
- ;;
-esac
-
-
dnl
dnl OSMesa configuration
dnl
@@ -1928,6 +1925,7 @@ dnl Substitute the config
AC_CONFIG_FILES([configs/autoconf
src/mesa/drivers/dri/i915/Makefile
src/mesa/drivers/dri/i965/Makefile
+ src/mesa/drivers/dri/r200/Makefile
src/mesa/drivers/dri/radeon/Makefile
tests/Makefile
tests/glx/Makefile])