summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2012-01-26 22:37:06 -0500
committerMatt Turner <mattst88@gmail.com>2012-01-30 21:09:18 -0500
commit275ac7e5c1fd6c1847a428192fe259e50690fced (patch)
tree133f533526e15904a3c10b3aa3dee4e11ec43909 /configure.ac
parente3b520049675f78065eccbc25c001ea77861c129 (diff)
automake: src/mesa/drivers/osmesa
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d42a52941b..9481798771 100644
--- a/configure.ac
+++ b/configure.ac
@@ -299,6 +299,8 @@ xnono )
enable_static=yes
;;
esac
+AM_CONDITIONAL(BUILD_STATIC, test "x$enable_static" = xyes)
+AM_CONDITIONAL(BUILD_SHARED, test "x$enable_shared" = xyes)
dnl
dnl mklib options
@@ -1331,6 +1333,9 @@ x16|x32)
AC_MSG_ERROR([OSMesa bits '$osmesa_bits' is not a valid option])
;;
esac
+AM_CONDITIONAL(HAVE_OSMESA8, test "x$osmesa_bits" = x8)
+AM_CONDITIONAL(HAVE_OSMESA16, test "x$osmesa_bits" = x16)
+AM_CONDITIONAL(HAVE_OSMESA32, test "x$osmesa_bits" = x32)
if test "x$enable_osmesa" = xyes; then
# only link libraries with osmesa if shared
@@ -1339,12 +1344,9 @@ if test "x$enable_osmesa" = xyes; then
else
OSMESA_LIB_DEPS=""
fi
- OSMESA_MESA_DEPS=""
OSMESA_PC_LIB_PRIV="-lm -lpthread $SELINUX_LIBS $DLOPEN_LIBS"
fi
AC_SUBST([OSMESA_LIB_DEPS])
-AC_SUBST([OSMESA_MESA_DEPS])
-AC_SUBST([OSMESA_PC_REQ])
AC_SUBST([OSMESA_PC_LIB_PRIV])
dnl
@@ -1929,6 +1931,8 @@ AC_CONFIG_FILES([configs/autoconf
src/mesa/drivers/dri/r200/Makefile
src/mesa/drivers/dri/radeon/Makefile
src/mesa/drivers/dri/swrast/Makefile
+ src/mesa/drivers/osmesa/osmesa.pc
+ src/mesa/drivers/osmesa/Makefile
tests/Makefile
tests/glx/Makefile])