summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2012-01-14 11:10:06 -0500
committerMatt Turner <mattst88@gmail.com>2012-01-26 19:36:52 -0500
commit0c1782316721cbf8391e01aa6fd083c34aec01a0 (patch)
tree41e46b30e9cb91b1fc05f9a7272de5731be1becb /configure.ac
parent80aa78142d12b21dd7d4f0edc786af98a159a80f (diff)
configure.ac: remove shared/static options
now that libtool provides them.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 1 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index e41e13aab9..507cfff768 100644
--- a/configure.ac
+++ b/configure.ac
@@ -273,39 +273,9 @@ if test "x$enable_64bit" = xyes; then
fi
fi
-dnl
-dnl shared/static libraries, mimic libtool options
-dnl
-AC_ARG_ENABLE([static],
- [AS_HELP_STRING([--enable-static],
- [build static libraries @<:@default=disabled@:>@])],
- [enable_static="$enableval"],
- [enable_static=no]
-)
-case "x$enable_static" in
-xyes|xno ) ;;
-x ) enable_static=no ;;
-* )
- AC_MSG_ERROR([Static library option '$enable_static' is not a valid])
- ;;
-esac
-AC_ARG_ENABLE([shared],
- [AS_HELP_STRING([--disable-shared],
- [build shared libraries @<:@default=enabled@:>@])],
- [enable_shared="$enableval"],
- [enable_shared=yes]
-)
-case "x$enable_shared" in
-xyes|xno ) ;;
-x ) enable_shared=yes ;;
-* )
- AC_MSG_ERROR([Shared library option '$enable_shared' is not a valid])
- ;;
-esac
-
dnl Can't have static and shared libraries, default to static if user
dnl explicitly requested. If both disabled, set to static since shared
-dnl was explicitly requirested.
+dnl was explicitly requested.
case "x$enable_static$enable_shared" in
xyesyes )
AC_MSG_WARN([Can't build static and shared libraries, disabling shared])