summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPekka Paalanen <ppaalanen@gmail.com>2012-01-31 16:35:19 +0200
committerKristian Høgsberg <krh@bitplanet.net>2012-01-31 09:41:06 -0500
commitf571d6337267a618ec8533fd5a72b79a19884868 (patch)
tree9ed093b2a477e0f54f10de7b844ae2022f91e1cd /configure.ac
parent51d2195937c4b02e1ab54b4ef382dc765f22ac6c (diff)
configure: use --disable-tests, since default is enabled
Add a nice help text, too. Signed-off-by: Pekka Paalanen <ppaalanen@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8478097..7bc9881 100644
--- a/configure.ac
+++ b/configure.ac
@@ -149,7 +149,10 @@ AC_ARG_ENABLE(tablet-shell, [ --enable-tablet-shell],,
AM_CONDITIONAL(ENABLE_TABLET_SHELL,
test x$enable_tablet_shell == xyes)
-AC_ARG_ENABLE(tests, [ --enable-tests],,enable_tests=yes)
+AC_ARG_ENABLE(tests,
+ AS_HELP_STRING([--disable-tests],
+ [do not build unit tests [default=enabled]]),,
+ enable_tests=yes)
AM_CONDITIONAL(BUILD_TESTS, test x$enable_tests == xyes)
if test "x$GCC" = "xyes"; then