summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPekka Paalanen <ppaalanen@gmail.com>2012-02-01 11:31:31 +0200
committerPekka Paalanen <ppaalanen@gmail.com>2012-02-01 12:12:19 +0200
commit0e4452e02a1036e7c85059762cd7b5f5aede1eaa (patch)
treeb40ba6e0bdcaa24d80343b3da68e7419a91bf346 /configure.ac
parent0452abc8203e2c037f074c059b9952b9410ccbdd (diff)
configure: add libpng to client libs
http://lists.freedesktop.org/archives/wayland-devel/2012-January/001975.html reports a linking problem: /usr/bin/ld: libtoytoolkit.a(cairo-util.o): undefined reference to symbol 'png_set_filler@@PNG12_0' /usr/bin/ld: note: 'png_set_filler@@PNG12_0' is defined in DSO /usr/lib/i386-linux-gnu/libpng12.so.0 so try adding it to the linker command line /usr/lib/i386-linux-gnu/libpng12.so.0: could not read symbols: Invalid operation collect2: ld returned 1 exit status make[3]: [weston-terminal] Error 1 (ignored) A similar problem is diagnosed here: http://lists.fedoraproject.org/pipermail/devel/2010-March/133601.html As some distros are shipping linkers, that do not resolve symbols from implicitly linked libraries, check and link libpng explicitly. Cc: nerdopolis <bluescreen_avenger@verizon.net> Signed-off-by: Pekka Paalanen <ppaalanen@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7bc9881..550bb3c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,7 +117,7 @@ AM_CONDITIONAL(BUILD_CLIENTS, test x$enable_clients == xyes)
if test x$enable_clients == xyes; then
AC_DEFINE([BUILD_CLIENTS], [1], [Build the Wayland clients])
- PKG_CHECK_MODULES(CLIENT, [wayland-client wayland-egl egl >= 7.10 cairo >= 1.10.0 gdk-pixbuf-2.0 glib-2.0 gobject-2.0 gio-2.0 xkbcommon])
+ PKG_CHECK_MODULES(CLIENT, [wayland-client wayland-egl egl >= 7.10 cairo >= 1.10.0 gdk-pixbuf-2.0 glib-2.0 gobject-2.0 gio-2.0 xkbcommon libpng])
PKG_CHECK_MODULES(POPPLER, [poppler-glib],
[have_poppler=yes], [have_poppler=no])