summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRyan C. Gordon <icculus@icculus.org>2011-10-13 16:35:25 -0400
committerRyan C. Gordon <icculus@icculus.org>2011-10-13 16:35:25 -0400
commitf9e61a2ccc8343a59f3825ab2ee2cf304e85426d (patch)
tree9a0731c73572e89910f0ff2d30f3e46070c7a463 /configure.in
parent45b644d1a90b72630f3304077f21b372488ebc4e (diff)
Don't warn about multichar characters on BeOS/Haiku.
The system headers use them generously. (transplanted from 825e1072eac6c950ca4f6e879a91ea199a282b2c) --HG-- extra : transplant_source : %82%5E%10r%EA%C6%C9P%CAOn%87%9A%91%EA%19%9A%28%2B%2C
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8c0c3d96..22799b9b 100644
--- a/configure.in
+++ b/configure.in
@@ -958,6 +958,19 @@ CheckWarnAll()
if test x$have_gcc_Wall = xyes; then
EXTRA_CFLAGS="$EXTRA_CFLAGS -Wall"
+
+ dnl Haiku headers use multicharacter constants all over the place. Ignore these warnings when using -Wall.
+ AC_MSG_CHECKING(for necessary GCC -Wno-multichar option)
+ need_gcc_Wno_multichar=no
+ case "$host" in
+ *-*-beos* | *-*-haiku*)
+ need_gcc_Wno_multichar=yes
+ ;;
+ esac
+ AC_MSG_RESULT($need_gcc_Wno_multichar)
+ if test x$need_gcc_Wno_multichar = xyes; then
+ EXTRA_CFLAGS="$EXTRA_CFLAGS -Wno-multichar"
+ fi
fi
}