summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSam Lantinga <slouken@libsdl.org>2011-02-08 10:04:09 -0800
committerSam Lantinga <slouken@libsdl.org>2011-02-08 10:04:09 -0800
commit7133afac5f92ef80dc092d32112a6a6ad3d31203 (patch)
tree7a6aee2c34863232ecf58fa47a8ec41451ace1f4 /configure.in
parent8f205278b1b17491279538e6c505946e1ca342d1 (diff)
Made it possible to disable the rendering subsystem with configure --disable-render
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 252f15f4..454c3db8 100644
--- a/configure.in
+++ b/configure.in
@@ -362,6 +362,12 @@ AC_HELP_STRING([--enable-video], [Enable the video subsystem [[default=yes]]]),
if test x$enable_video != xyes; then
AC_DEFINE(SDL_VIDEO_DISABLED)
fi
+AC_ARG_ENABLE(render,
+AC_HELP_STRING([--enable-render], [Enable the render subsystem [[default=yes]]]),
+ , enable_render=yes)
+if test x$enable_render != xyes; then
+ AC_DEFINE(SDL_RENDER_DISABLED)
+fi
AC_ARG_ENABLE(events,
AC_HELP_STRING([--enable-events], [Enable the events subsystem [[default=yes]]]),
, enable_events=yes)