summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2011-10-14 14:34:19 -0700
committerEric Anholt <eric@anholt.net>2011-10-28 11:32:00 -0700
commit830e546f94c53d3f6878a188a2bdb5d2f3cf74bd (patch)
treeccf2a170c2f9faf5e93ca8e3571f7c80613dd512 /configure.ac
parent48c9925367034b6fac506f1f32d445c5bd825a49 (diff)
radeon: Insist on libdrm being present to build.
There's no sense in building a broken driver. Previously, there was the potential of building a DRI1-only driver that would work for DRI1 and fail on DRI2 because the newer libdrm code wasn't present. Now the radeon build system should be matching intel and nouveau.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 1 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index ab3ba25e93..29da959e22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1277,19 +1277,9 @@ esac
case $DRI_DIRS in
*radeon*|*r200*)
- PKG_CHECK_MODULES([LIBDRM_RADEON],
- [libdrm_radeon >= $LIBDRM_RADEON_REQUIRED],
- HAVE_LIBDRM_RADEON=yes,
- HAVE_LIBDRM_RADEON=no)
-
- if test "x$HAVE_LIBDRM_RADEON" = xyes; then
- RADEON_CFLAGS="-DHAVE_LIBDRM_RADEON=1 $LIBDRM_RADEON_CFLAGS"
- RADEON_LDFLAGS=$LIBDRM_RADEON_LIBS
- fi
+ PKG_CHECK_MODULES([RADEON], [libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
;;
esac
-AC_SUBST([RADEON_CFLAGS])
-AC_SUBST([RADEON_LDFLAGS])
dnl