summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c9cc2a88..dbb33592 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,6 +50,21 @@ if (X11_FOUND)
endif ()
endif (X11_FOUND)
+if (CMAKE_COMPILER_IS_GNUCC)
+ add_definitions(
+ -Wall
+ -Wpointer-arith
+ -Wstrict-prototypes
+ -Wmissing-prototypes
+ -Wmissing-declarations
+ -Wnested-externs
+ -fno-strict-aliasing
+ -Wbad-function-cast
+ #-Wold-style-definition
+ #-Wdeclaration-after-statement
+ )
+endif (CMAKE_COMPILER_IS_GNUCC)
+
if (WIN32)
# Nobody likes to include windows.h:
# - Microsoft's GL/gl.h header depends on windows.h but doesn't include it;