summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <thibault.saunier@osg.samsung.com>2016-09-30 11:35:39 -0300
committerThibault Saunier <thibault.saunier@osg.samsung.com>2016-09-30 12:57:51 -0300
commitb910ecca68f8a54fa2bf9485f096fc2b796418e4 (patch)
treed84b417a5f54770dd03e0afb9423c4416a36ceb6 /meson.build
parent00d20b044ce7b9340401c25a4b7d06e67ecf2bc0 (diff)
meson: Setup pre commit hook and fix getpluginsdir for standalone case
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7778598cc..eee13a3dd 100644
--- a/meson.build
+++ b/meson.build
@@ -246,3 +246,6 @@ subdir('po')
configure_file(input : 'config.h.meson',
output : 'config.h',
configuration : cdata)
+
+python3 = find_program('python3')
+run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')