summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorScott D Phillips <scott.d.phillips@intel.com>2016-10-26 22:37:34 -0700
committerTim-Philipp Müller <tim@centricular.com>2016-11-11 16:00:41 +0000
commit5a7c3429225a42982834f77d91e0ccb7d8879242 (patch)
treedf46df1678badd253945ff63da5483f1d04861e1 /meson.build
parentadeee44b07a173b9ab4253216caba8f66dd43abb (diff)
meson: don't add_global_arguments when being built as a subproject
https://bugzilla.gnome.org/show_bug.cgi?id=773568
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 87aeb349e..f7eee449a 100644
--- a/meson.build
+++ b/meson.build
@@ -29,7 +29,9 @@ if cc.get_id() == 'msvc'
# If a warning is completely useless and spammy, use '/wdXXXX' to suppress it
# If a warning is harmless but hard to fix, use '/woXXXX' so it's shown once
# NOTE: Only add warnings here if you are sure they're spurious
- add_global_arguments('/wd4018', '/wd4244', '/wd4996', language : 'c')
+ if not meson.is_subproject()
+ add_global_arguments('/wd4018', '/wd4244', '/wd4996', language : 'c')
+ endif
# Disable SAFESEH with MSVC for plugins and libs that use external deps that
# are built with MinGW
noseh_link_args = ['/SAFESEH:NO']