summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-06-26 09:47:55 +0100
committerTim-Philipp Müller <tim@centricular.com>2017-06-26 09:47:58 +0100
commit4e2095bd5ea036b4b86ec966f1317fa92cf3fa96 (patch)
treeb2974dba69d79d9b50813766ff64d4d24996629c /meson.build
parent0fd4a11711a234457bb2d4276176c6dd818f2a9b (diff)
meson: fix with-package-name option
https://bugzilla.gnome.org/show_bug.cgi?id=784082
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 45b06ba05..bdef99135 100644
--- a/meson.build
+++ b/meson.build
@@ -135,13 +135,14 @@ cdata.set('GETTEXT_PACKAGE', '"gst-plugins-good-1.0"')
gst_package_name = get_option('with-package-name')
if gst_package_name == ''
if gst_version_nano == 0
- cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer Good Plug-ins source release')
+ gst_package_name = 'GStreamer Good Plug-ins source release'
elif gst_version_nano == 1
- cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer Good Plug-ins git')
+ gst_package_name = 'GStreamer Good Plug-ins git'
else
- cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer Good Plug-ins prerelease')
+ gst_package_name = 'GStreamer Good Plug-ins prerelease'
endif
endif
+cdata.set_quoted('GST_PACKAGE_NAME', gst_package_name)
cdata.set_quoted('GST_PACKAGE_ORIGIN', get_option('with-package-origin'))
# Mandatory GST deps