summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-05-20 14:46:51 +0100
committerTim-Philipp Müller <tim@centricular.com>2017-05-20 14:46:51 +0100
commit7fb0aeac10b2927607bf098d61faf04488987866 (patch)
tree64ac92fbac61ca634fcf4fdd34fba25a40c43cb4 /meson.build
parent3b3bc34e9ab167f1a6c69b2ed6c4edeee0356925 (diff)
meson: add options to set package name and origin
https://bugzilla.gnome.org/show_bug.cgi?id=782172
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 14 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 225eaee02..a8d4ee83d 100644
--- a/meson.build
+++ b/meson.build
@@ -99,12 +99,24 @@ core_conf.set('GETTEXT_PACKAGE', '"gst-plugins-base-1.0"')
core_conf.set('PACKAGE', '"gst-plugins-base"')
core_conf.set('VERSION', '"@0@"'.format(gst_version))
core_conf.set('PACKAGE_VERSION', '"@0@"'.format(gst_version))
-core_conf.set('GST_PACKAGE_NAME', '"GStreamer Base Plug-ins"')
-core_conf.set('GST_PACKAGE_ORIGIN', '"Unknown package origin"')
core_conf.set('GST_API_VERSION', '"@0@"'.format(api_version))
core_conf.set('GST_INSTALL_PLUGINS_HELPER', '"/FIXME"')
core_conf.set('GST_DATADIR', '"/FIXME"')
core_conf.set('GST_LICENSE', '"LGPL"')
+
+# GStreamer package name and origin url
+gst_package_name = get_option('with-package-name')
+if gst_package_name == ''
+ if gst_version_nano == 0
+ core_conf.set_quoted('GST_PACKAGE_NAME', 'GStreamer Base Plug-ins source release')
+ elif gst_version_nano == 1
+ core_conf.set_quoted('GST_PACKAGE_NAME', 'GStreamer Base Plug-ins git')
+ else
+ core_conf.set_quoted('GST_PACKAGE_NAME', 'GStreamer Base Plug-ins prerelease')
+ endif
+endif
+core_conf.set_quoted('GST_PACKAGE_ORIGIN', get_option('with-package-origin'))
+
# FIXME: These should be configure options
core_conf.set('DEFAULT_VIDEOSINK', '"autovideosink"')
core_conf.set('DEFAULT_AUDIOSINK', '"autoaudiosink"')