summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2016-10-03 08:56:55 +0100
committerTim-Philipp Müller <tim@centricular.com>2016-10-03 08:56:55 +0100
commit0e82516f099e94065f46d6ac5fa2d23ef2aaed6f (patch)
tree467454dafb5141b1041069c65348b27fc1406012 /meson.build
parent87905cc48b6c3104eddfb4e486c6cb1f3a3f40b6 (diff)
meson: require orc 0.4.24 here too
Needed for some video stuff. Same requirement as in the autotools build.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 75de4a356..93a1a425b 100644
--- a/meson.build
+++ b/meson.build
@@ -17,6 +17,7 @@ else
endif
glib_req = '>= 2.40.0'
+orc_req = '>= 0.4.24'
gst_req = '>= @0@.@1@.0'.format(gst_version_major, gst_version_minor)
api_version = '1.0'
@@ -162,7 +163,7 @@ orcc_args = []
if get_option('use_orc') != 'no'
need_orc = get_option('use_orc') == 'yes'
# Used by various libraries/elements that use Orc code
- orc_dep = dependency('orc-0.4', version : '>= 0.4.17', required : need_orc)
+ orc_dep = dependency('orc-0.4', version : orc_req, required : need_orc)
orcc = find_program('orcc', required : need_orc)
if orc_dep.found() and orcc.found()
have_orcc = true