summaryrefslogtreecommitdiff
path: root/ext/dts/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'ext/dts/meson.build')
-rw-r--r--ext/dts/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/ext/dts/meson.build b/ext/dts/meson.build
index 882a6aa89..6bbf95a6e 100644
--- a/ext/dts/meson.build
+++ b/ext/dts/meson.build
@@ -4,10 +4,14 @@ if not dca_dep.found() and cc.has_header_symbol('dca.h', 'dca_init')
dca_dep = cc.find_library('dca', required : false)
endif
+# autotools didn't use the libdca pkg-config cflags, and they
+# can point to a non-existing location (/usr/include/dca)
+no_warn_c_args = ['-Wno-missing-include-dirs']
+
if dca_dep.found()
gstdtsdec = library('gstdtsdec',
'gstdtsdec.c',
- c_args : gst_plugins_bad_args,
+ c_args : gst_plugins_bad_args + no_warn_c_args,
link_args : noseh_link_args,
include_directories : [configinc, libsinc],
dependencies : [gstaudio_dep, orc_dep, dca_dep],