summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Frisch <fraxinas@dreambox.guru>2017-10-19 16:01:46 +0200
committerSebastian Dröge <sebastian@centricular.com>2017-10-19 16:46:24 +0200
commit07d6b7f56d68a6465f34fa85accc1db0238f4440 (patch)
tree2cfd002a7db12f361f602e5192a9ee866ca27192 /configure.ac
parent519ead2462ca2295cee4f84006464168e7aa6bd7 (diff)
lcms: Add LCMS ICC color correction element
https://bugzilla.gnome.org/show_bug.cgi?id=765927
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index df58fc594..4aa55d778 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2480,6 +2480,15 @@ AG_GST_CHECK_FEATURE(LADSPA, [ladspa], ladspa, [
AC_SUBST(LRDF_CFLAGS)
])
+dnl *** LCM2 ***
+#translit(dnm, m, l) AM_CONDITIONAL(USE_LCMS2, true)
+AG_GST_CHECK_FEATURE(LCMS2, [LCMS colormanagement plugin], lcms2, [
+ PKG_CHECK_MODULES(LCMS2, lcms2 >= 2.7, HAVE_LCMS2="yes", [
+ HAVE_LCMS2="no"
+ ])
+ AC_SUBST(LCMS2_LIBS)
+])
+
dnl *** LV2 ***
translit(dnm, m, l) AM_CONDITIONAL(USE_LV2, true)
AG_GST_CHECK_FEATURE(LV2, [lv2], lv2, [
@@ -3454,6 +3463,7 @@ AM_CONDITIONAL(USE_KATE, false)
AM_CONDITIONAL(USE_KMS, false)
AM_CONDITIONAL(USE_TIGER, false)
AM_CONDITIONAL(USE_LADSPA, false)
+AM_CONDITIONAL(USE_LCMS2, false)
AM_CONDITIONAL(USE_LV2, false)
AM_CONDITIONAL(USE_LIBDE265, false)
AM_CONDITIONAL(USE_LIBMMS, false)
@@ -3739,6 +3749,7 @@ ext/assrender/Makefile
ext/bs2b/Makefile
ext/bz2/Makefile
ext/chromaprint/Makefile
+ext/colormanagement/Makefile
ext/curl/Makefile
ext/dash/Makefile
ext/dc1394/Makefile