summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>2008-10-08 13:11:54 +0000
committerMark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>2008-10-08 13:11:54 +0000
commitd0877c48e4b495de588a5e5d3f8ec9178c6b14aa (patch)
tree024cf3fea09f447450845e1704f108b166c804a6 /configure.ac
parentb706c481d32438a637fb448fda8de20be3d1b3fa (diff)
Rewrite ffvideoscale using libswscale and put into a separate plugin.
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/libswscale/Makefile.am: * ext/libswscale/gstffmpegscale.c: (gst_ffmpegscale_method_get_type), (gst_ffmpegscale_base_init), (gst_ffmpegscale_class_init), (gst_ffmpegscale_init), (gst_ffmpegscale_reset), (gst_ffmpegscale_finalize), (gst_ffmpegscale_caps_remove_format_info), (gst_ffmpegscale_transform_caps), (gst_ffmpegscale_fixate_caps), (gst_ffmpegscale_get_unit_size), (gst_ffmpeg_caps_to_pixfmt), (gst_ffmpegscale_fill_info), (gst_ffmpegscale_set_caps), (gst_ffmpegscale_transform), (gst_ffmpegscale_handle_src_event), (gst_ffmpegscale_stop), (gst_ffmpegscale_set_property), (gst_ffmpegscale_get_property), (gst_ffmpeg_log_callback), (plugin_init): Rewrite ffvideoscale using libswscale and put into a separate plugin. Fixes #504056.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index db9ba32..3f8e7c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -212,6 +212,7 @@ AC_ARG_WITH(system-ffmpeg,
if test "x$with_system_ffmpeg" = "xyes"; then
PKG_CHECK_MODULES(FFMPEG, libavutil libavcodec libavformat)
PKG_CHECK_MODULES(POSTPROC, libavcodec libpostproc)
+ PKG_CHECK_MODULES(SWSCALE, libavutil libswcale)
saved_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS $FFMPEG_CFLAGS"
AC_CHECK_HEADERS([avi.h])
@@ -278,6 +279,16 @@ else
POSTPROC_LIBS="\$(top_builddir)/gst-libs/ext/ffmpeg/libpostproc/libpostproc.a \
\$(top_builddir)/gst-libs/ext/ffmpeg/libavutil/libavutil.a"
+ dnl
+ SWSCALE_CFLAGS="-I \$(top_srcdir)/gst-libs/ext/ffmpeg/libswscale \
+ -I \$(top_srcdir)/gst-libs/ext/ffmpeg/libavutil \
+ -I \$(top_srcdir)/gst-libs/ext/ffmpeg \
+ -Wno-deprecated-declarations"
+
+ dnl libgstswscale.la: libs to statically link to
+ SWSCALE_LIBS="\$(top_builddir)/gst-libs/ext/ffmpeg/libswscale/libswscale.a \
+ \$(top_builddir)/gst-libs/ext/ffmpeg/libavutil/libavutil.a"
+
FFMPEG_SUBDIRS=gst-libs
AC_DEFINE(HAVE_AVI_H)
AC_DEFINE([FFMPEG_SOURCE], ["local snapshot"], [Describes where the FFmpeg libraries come from.])
@@ -288,7 +299,7 @@ else
with_ffmpeg_extra_configure=no)
# Enable shared and static so that we get .a files, but with PIC code.
- ac_configure_args="$ac_configure_args --disable-vhook --disable-ffserver --disable-ffplay --enable-postproc --enable-gpl --enable-static --enable-shared --disable-encoder=flac --disable-decoder=cavs --disable-protocols --disable-devices --disable-network"
+ ac_configure_args="$ac_configure_args --disable-vhook --disable-ffserver --disable-ffplay --enable-postproc --enable-swscale --enable-gpl --enable-static --enable-shared --disable-encoder=flac --disable-decoder=cavs --disable-protocols --disable-devices --disable-network"
# if we are cross-compiling, tell ffmpeg so
if test "x$cross_compiling" = xyes; then
@@ -330,6 +341,8 @@ AC_SUBST(FFMPEG_LIBS)
AC_SUBST(FFMPEG_SUBDIRS)
AC_SUBST(POSTPROC_CFLAGS)
AC_SUBST(POSTPROC_LIBS)
+AC_SUBST(SWSCALE_CFLAGS)
+AC_SUBST(SWSCALE_LIBS)
AC_SUBST(WIN32_LIBS)
if test x$HAVE_FFMPEG_UNINSTALLED = x1; then
@@ -343,6 +356,7 @@ gst-ffmpeg.spec
ext/Makefile
ext/ffmpeg/Makefile
ext/libpostproc/Makefile
+ext/libswscale/Makefile
gst-libs/Makefile
gst-libs/ext/Makefile
docs/Makefile