summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2010-03-24 11:49:52 +0100
committerEdward Hervey <bilboed@bilboed.com>2010-03-24 11:49:52 +0100
commit9cdbe4a57500f4c7af3e77be6fa174094fe008a2 (patch)
treef32df98ed5b002288a7e4217f72f3909856592b6 /configure.ac
parent34b71b4d4c139f03d0ad8643ef220f6b4062eacd (diff)
build: Add all kinds of compiler warning flags and fix the resulting warnings
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a92a10a..4813e29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,7 @@ dnl define PACKAGE_VERSION_* variables
AS_VERSION
dnl check if this is a release version
-AS_NANO(GST_CVS="no", GST_CVS="yes")
+AS_NANO(GST_GIT="no", GST_GIT="yes")
dnl can autoconf find the source ?
AC_CONFIG_SRCDIR([gnl/gnl.c])
@@ -146,10 +146,14 @@ dnl set location of plugin directory
AG_GST_SET_PLUGINDIR
dnl define an ERROR_CFLAGS Makefile variable
-AG_GST_SET_ERROR_CFLAGS($GST_CVS)
+AG_GST_SET_ERROR_CFLAGS($GST_GIT, [-Wmissing-declarations -Wmissing-prototypes
+ -Wredundant-decls -Wundef -Wwrite-strings -Wformat-nonliteral
+ -Wformat-security -Wold-style-definition -Wcast-align -Winit-self
+ -Wmissing-include-dirs -Waddress -Waggregate-return -Wno-multichar
+ -Wnested-externs])
dnl define correct level for debugging messages
-AG_GST_SET_LEVEL_DEFAULT($GST_CVS)
+AG_GST_SET_LEVEL_DEFAULT($GST_GIT)
dnl used in examples
AG_GST_DEFAULT_ELEMENTS
@@ -170,7 +174,7 @@ if test "x$USE_DEBUG" = xyes; then
fi
AC_SUBST(PROFILE_CFLAGS)
-if test "x$GST_CVS" = "xyes"; then
+if test "x$GST_GIT" = "xyes"; then
DEPRECATED_CFLAGS="-DGST_DISABLE_DEPRECATED"
else
DEPRECATED_CFLAGS=""