summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Henstridge <james@daa.com.au>2003-03-04 10:10:48 +0000
committerJames Henstridge <jamesh@src.gnome.org>2003-03-04 10:10:48 +0000
commitc4391cbf37536440e7cf6c21f4731f19833f59f9 (patch)
tree4f41dd52fec863e76b41657636e60249ec56ee02 /Makefile.am
parent6f988777288b6e2319dddea6ed0081ec242e71a0 (diff)
require automake 1.7. Add calls to libtoolize and gtkdocize. Clean up some
2003-03-01 James Henstridge <james@daa.com.au> * autogen.sh: require automake 1.7. Add calls to libtoolize and gtkdocize. Clean up some of the error messages. * configure.in: move version declaration to the top of the file (before AC_INIT), using M4 macros. GLIB_AC_DIVERT_BEFORE_HELP() calls no longer necessary, due to use of M4 macro expansion in help messages instead. Convert AC_ARG_WITH/AC_ARG_ENABLE calls to use AC_HELP_STRING to format help strings. Use quadrigraphs to get square brackets to show correctly. Replace gtk-doc checks with a call to GTK_DOC_CHECK() macro. Use AC_CONFIG_COMMANDS([glibconfig.h], ...) to output glibconfig.h, so that "./config.status glibconfig.h" works. Add an extra AC_CONFIG_FILES call listing other files we want generated by config.status protected by an "if false" block. This way automake generates the rules needed to rebuild the files for us. Add quotes in various places. * docs/reference/*/Makefile.am: convert to use the common gtk-doc.make file. This localises the complexity to a single makefile fragment maintained with gtk-doc itself. * */Makefile.am: remove unneeded rules to build win32 files with config.status. Automake now does this for us. Replace instances of @FOO@ with $(FOO) where appropriate -- this allows automake to do a better job checking the makefile. Add some files to DISTCLEANFILES where appropriate * Makefile.am: use the DISTCHECK_CONFIGURE_FLAGS variable to ensure that --enable-gtk-doc is passed to configure during a distcheck. Remove the custom distcheck, since the standard one will now do. * gobject/Makefile.am: switch to BUILT_SOURCES, since that now works.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am52
1 files changed, 17 insertions, 35 deletions
diff --git a/Makefile.am b/Makefile.am
index 25b1799ae..f1b204a97 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in
-AUTOMAKE_OPTIONS = 1.4
+AUTOMAKE_OPTIONS = 1.7
SUBDIRS = . m4macros glib gobject gmodule gthread tests build po docs
@@ -33,10 +33,13 @@ EXTRA_DIST = \
glib-2.0-uninstalled.pc.in \
gobject-2.0-uninstalled.pc.in \
gmodule-2.0-uninstalled.pc.in \
- gthread-2.0-uninstalled.pc.in
+ gthread-2.0-uninstalled.pc.in \
+ gtk-doc.make
# These may be in the builddir too
BUILT_EXTRA_DIST = \
+ README \
+ INSTALL \
glibconfig.h.win32 \
config.h.win32
@@ -50,6 +53,9 @@ install-exec-local: glibconfig.h
if test -r $$file && cmp -s glibconfig.h $$file; then :; \
else $(INSTALL_DATA) glibconfig.h $$file; fi
+uninstall-local:
+ rm -f $(DESTDIR)$(configexecincludedir)/glibconfig.h
+
CONFIGURE_DEPENDENCIES = acglib.m4
BUILT_SOURCES = stamp-gc-h #note: not glibconfig.h
@@ -57,23 +63,24 @@ glibconfig.h: stamp-gc-h
@if test -f glibconfig.h; then :; \
else rm -f stamp-gc-h; $(MAKE) stamp-gc-h; fi
stamp-gc-h: config.status
- CONFIG_FILES= CONFIG_HEADERS= CONFIG_OTHER=glibconfig.h ./config.status
+ cd $(top_builddir) && $(SHELL) ./config.status glibconfig.h
echo timestamp > stamp-gc-h
-
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = glib-2.0.pc gobject-2.0.pc gmodule-2.0.pc gthread-2.0.pc
$(pkgconfig_DATA): config.status
-glibconfig.h.win32: $(top_builddir)/config.status $(top_srcdir)/glibconfig.h.win32.in
- cd $(top_builddir) && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
-
-config.h.win32: $(top_builddir)/config.status $(top_srcdir)/config.h.win32.in
- cd $(top_builddir) && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
+# build documentation when doing distcheck
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
DISTCLEANFILES = glibconfig-sysdefs.h glibconfig.h stamp-gc-h
+distclean-local:
+ if test $(srcdir) = .; then :; else \
+ rm -f $(BUILT_EXTRA_DIST); \
+ fi
+
.PHONY: files release sanity snapshot
files:
@@ -96,32 +103,7 @@ snapcheck:
$(MAKE) distcheck distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
dist-hook: $(BUILT_EXTRA_DIST)
- cd $(top_builddir) && CONFIG_FILES="INSTALL README" CONFIG_HEADERS= $(SHELL) ./config.status
- files='$(BUILT_EXTRA_DIST) INSTALL README'; \
+ files='$(BUILT_EXTRA_DIST)'; \
for f in $$files; do \
if test -f $$f; then d=.; else d=$(srcdir); fi; \
rm -f $(distdir)/$$f && cp $$d/$$f $(distdir) || exit 1; done
-
-# This is a version of the automake-1.4 distcheck rule modified
-# to pass --enable-gtk-doc to ./configure
-#
-mydistcheck: dist
- -rm -rf $(distdir)
- GZIP=$(GZIP_ENV) $(TAR) zxf $(distdir).tar.gz
- mkdir $(distdir)/=build
- mkdir $(distdir)/=inst
- dc_install_base=`cd $(distdir)/=inst && pwd`; \
- cd $(distdir)/=build \
- && ../configure --srcdir=.. --prefix=$$dc_install_base --enable-gtk-doc \
- && $(MAKE) $(AM_MAKEFLAGS) \
- && $(MAKE) $(AM_MAKEFLAGS) dvi \
- && $(MAKE) $(AM_MAKEFLAGS) check \
- && $(MAKE) $(AM_MAKEFLAGS) install \
- && $(MAKE) $(AM_MAKEFLAGS) installcheck \
- && $(MAKE) $(AM_MAKEFLAGS) dist
- -rm -rf $(distdir)
- @banner="$(distdir).tar.gz is ready for distribution"; \
- dashes=`echo "$$banner" | sed s/./=/g`; \
- echo "$$dashes"; \
- echo "$$banner"; \
- echo "$$dashes"