summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRyan Lortie <desrt@desrt.ca>2013-01-18 13:56:10 -0500
committerRyan Lortie <desrt@desrt.ca>2013-01-18 13:57:07 -0500
commit614f6c5e7073737cf1f531120287688859f88bd7 (patch)
tree99c633c0da4b0686972a61b127f72dab5541ff93 /Makefile.am
parent52a81a7d86102604729ba07824f1ae6a45b51cea (diff)
Add new API checking utility
Add a test script to make sure that (with a few exceptions) only symbols that start with 'g_' are being exported from our public libraries. https://bugzilla.gnome.org/show_bug.cgi?id=692029
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5df81cc3a..b2555adc6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,6 +16,10 @@ endif
bin_SCRIPTS = glib-gettextize
+if OS_LINUX
+TESTS = check-abis.sh
+endif
+
AM_CPPFLAGS = \
-DG_LOG_DOMAIN=g_log_domain_glib \
@GLIB_DEBUG_FLAGS@ \
@@ -58,7 +62,8 @@ EXTRA_DIST += \
gthread-2.0.pc.in \
gio-2.0.pc.in \
gio-unix-2.0.pc.in \
- gio-windows-2.0.pc.in
+ gio-windows-2.0.pc.in \
+ check-abis.sh
# These may be in the builddir too