summaryrefslogtreecommitdiff
path: root/hw/xfree86/parser/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xfree86/parser/Makefile.am')
-rw-r--r--hw/xfree86/parser/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/hw/xfree86/parser/Makefile.am b/hw/xfree86/parser/Makefile.am
index c0622090c..b8fab2835 100644
--- a/hw/xfree86/parser/Makefile.am
+++ b/hw/xfree86/parser/Makefile.am
@@ -1,13 +1,14 @@
if INSTALL_LIBXF86CONFIG
-lib_LTLIBRARIES = libxf86config.la
+noinst_LTLIBRARIES = libxf86config_internal.la
+lib_LIBRARIES = libxf86config.a
LIBHEADERS = \
xf86Optrec.h \
xf86Parser.h
else
-noinst_LTLIBRARIES = libxf86config.la
+noinst_LTLIBRARIES = libxf86config_internal.la
endif
-libxf86config_la_SOURCES = \
+INTERNAL_SOURCES= \
Device.c \
Files.c \
Flags.c \
@@ -25,6 +26,13 @@ libxf86config_la_SOURCES = \
DRI.c \
Extensions.c
+libxf86config_internal_la_SOURCES = \
+ $(INTERNAL_SOURCES)
+
+libxf86config_a_SOURCES = \
+ $(INTERNAL_SOURCES)
+libxf86config_a_CFLAGS = $(AM_CFLAGS)
+
AM_CFLAGS = $(DIX_CFLAGS) $(XORG_CFLAGS)
EXTRA_DIST = \