summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonny Lamb <jonny.lamb@collabora.co.uk>2011-09-06 13:24:39 +0100
committerJonny Lamb <jonny.lamb@collabora.co.uk>2011-09-07 14:56:56 +0100
commit42069fb5754f1ed1d146a660d9528e92bfc52200 (patch)
treeea93bbd3dd5b5ba362364e9cfbd45808b0de99d3 /configure.ac
parent59cc9b7c289b902580e3adbc6af08fe50f6bce75 (diff)
gabble: add beginning of gabble plugin
Signed-off-by: Jonny Lamb <jonny.lamb@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e6bd745..c7feb23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,6 +88,24 @@ AC_SUBST(TEST_PYTHON)
AM_CONDITIONAL([WANT_TWISTED_TESTS], test false != "$TEST_PYTHON")
# ------------------------------------------------------------------------------
+# GABBLE PLUGIN
+
+PKG_CHECK_MODULES(GABBLE, telepathy-gabble, HAVE_GABBLE=yes, HAVE_GABBLE=no)
+AC_SUBST(GABBLE_LIBS)
+AC_SUBST(GABBLE_CFLAGS)
+gabbleplugindir=`pkg-config --variable=plugindir telepathy-gabble`
+AC_SUBST(gabbleplugindir)
+
+AC_MSG_CHECKING([telepathy-gabble executable])
+GABBLE_EXECUTABLE=`pkg-config --variable=gabblepath telepathy-gabble`
+if test "$GABBLE_EXECUTABLE" = ""; then
+ AC_MSG_ERROR([could not determine location of telepathy-gabble executable])
+else
+ AC_MSG_RESULT([$GABBLE_EXECUTABLE])
+fi
+AC_SUBST(GABBLE_EXECUTABLE)
+
+# ------------------------------------------------------------------------------
AC_ARG_ENABLE(debug,
AC_HELP_STRING([--enable-debug],
@@ -113,6 +131,7 @@ AC_OUTPUT([
mission-control/Makefile
plugin-base/Makefile
salut/Makefile
+ gabble/Makefile
tests/Makefile
tests/twisted/Makefile
tests/twisted/tools/Makefile