summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2014-10-24 09:56:51 +0200
committerArun Raghavan <arun@accosted.net>2014-10-31 10:46:10 +0530
commit7d4a497b3db6e3c58fb5fe64131c8f81cade85b7 (patch)
tree341105d10bd83b81700b19621b2427aaf5356a20 /configure.ac
parentd7199bafea7be9ca26ee9a551e245de0f4bc9e29 (diff)
backend-native: add a new native headset backend
Add a simple native headset backend that implements support for the blutooth HSP profile. This allows pulseaudio to output audio to a Headset using the HSP profile. Make the native backend the default.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f807699de..f165eb4ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1036,14 +1036,14 @@ AM_CONDITIONAL([HAVE_BLUEZ], [test "x$HAVE_BLUEZ" = x1])
## Bluetooth Headset profiles backend ##
AC_ARG_WITH(bluetooth_headset_backend,
- AS_HELP_STRING([--with-bluetooth-headset-backend=<ofono|null>],[Backend for Bluetooth headset profiles (ofono)]))
+ AS_HELP_STRING([--with-bluetooth-headset-backend=<ofono|native|null>],[Backend for Bluetooth headset profiles (native)]))
if test -z "$with_bluetooth_headset_backend" ; then
- BLUETOOTH_HEADSET_BACKEND=ofono
+ BLUETOOTH_HEADSET_BACKEND=native
else
BLUETOOTH_HEADSET_BACKEND=$with_bluetooth_headset_backend
fi
-AS_IF([test "x$BLUETOOTH_HEADSET_BACKEND" != "xofono" && test "x$BLUETOOTH_HEADSET_BACKEND" != "xnull"],
+AS_IF([test "x$BLUETOOTH_HEADSET_BACKEND" != "xofono" && test "x$BLUETOOTH_HEADSET_BACKEND" != "xnull" && test "x$BLUETOOTH_HEADSET_BACKEND" != "xnative"],
[AC_MSG_ERROR([*** Invalid Bluetooth Headset backend])])
AC_SUBST(BLUETOOTH_HEADSET_BACKEND)