summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTanu Kaskinen <tanu.kaskinen@linux.intel.com>2015-05-20 22:35:27 +0300
committerDavid Henningsson <david.henningsson@canonical.com>2015-09-07 14:54:27 +0200
commit27d71c00d8d8bf07b5109dc016d53c7d8c3a1975 (patch)
tree019629a3bc4655e24987e2d754297a8b68a9956d /configure.ac
parent031ca878216c76a508da45fc086fa19509406771 (diff)
build-sys: check strtod_l instead of strtof_l
We have no strtof_l calls in the code, so it doesn't make sense to check that function's availability. We have one strtod_l call, so let's check that instead. I don't know if this change makes any practical difference. I just wondered why we had HAVE_STRTOF_L ifdefs in core-util.c for code that didn't use strtof_l.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 12512fcf8..093e8d8ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -572,7 +572,7 @@ AC_CHECK_FUNCS_ONCE([strerror_r])
AC_CHECK_FUNCS_ONCE([lstat])
# Non-standard
-AC_CHECK_FUNCS_ONCE([setresuid setresgid setreuid setregid seteuid setegid ppoll strsignal sig2str strtof_l pipe2 accept4])
+AC_CHECK_FUNCS_ONCE([setresuid setresgid setreuid setregid seteuid setegid ppoll strsignal sig2str strtod_l pipe2 accept4])
AC_FUNC_ALLOCA