summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorConnor Behan <connor.behan@gmail.com>2013-11-15 17:00:40 -0800
committerKeith Packard <keithp@keithp.com>2013-11-26 21:47:46 -0800
commitbd70def07754357d26b86c287037eb3884631daf (patch)
treed68952cb81dc5067d7284e06c009fbf5c01675a9 /configure.ac
parenta575c1dc64c10bc88bd0e963ebb8ab137f59a078 (diff)
configure.ac: Require libpciaccess for int10
A --disable-pciaccess build will fail with an int10 module other than stub. Signed-off-by: Connor Behan <connor.behan@gmail.com> Reviewed-by: Adam Jackson <ajax@redhat.com> Signed-off-by: Keith Packard <keithp@keithp.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7ec9479a..6197e9bed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1830,6 +1830,9 @@ if test "x$XORG" = xyes; then
if test "x$CONFIG_UDEV_KMS" = xyes; then
AC_MSG_ERROR([Platform device enumeration requires libpciaccess])
fi
+ if test "x$INT10" != xstub; then
+ AC_MSG_ERROR([Cannot build int10 without libpciaccess])
+ fi
fi
AC_MSG_RESULT([$PCI])