summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2014-01-22 19:17:24 -0800
committerKeith Packard <keithp@keithp.com>2014-01-27 11:38:36 -0800
commit0b5a87f37d5dcd2ebff977a3b9a50a75ace93c83 (patch)
treee03c20a7f74ce7bfe7c5ac3fdf8e0c17277f0e62 /configure.ac
parent61cb6c9aa95aa369573c4e02c023bbc33c7678c9 (diff)
pseudoramiX: Only compile on XQUARTZ and XWIN
PseudoramiXExtensionInit() is not defined in extinit.h if it won't be used and we get a compiler warning when compiling the pseudoramiX code. Signed-off-by: Keith Packard <keithp@keithp.com> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 560c46030..0312c4f51 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2174,6 +2174,8 @@ if test "x$XQUARTZ" = xyes; then
fi
fi
+AM_CONDITIONAL(PSEUDORAMIX, [test "x$XQUARTZ" = xyes -o "x$XWIN" = xyes ])
+
# Support for objc in autotools is minimal and not documented.
OBJC='$(CC)'
OBJCLD='$(CCLD)'