summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2013-04-09 19:59:39 -0700
committerKeith Packard <keithp@keithp.com>2013-10-31 16:58:30 -0700
commit563138298868f62501875d3016f03469dcffaad0 (patch)
treea63491ea60c8a0360351b0e163a8195ce22f697d /Makefile.am
parentfdec793cdc2ef9a6ea66b311cb1068a7bd4a3be3 (diff)
dri3: Add DRI3 extension
Adds DRM compatible fences using futexes. Uses FD passing to get pixmaps from DRM applications. Signed-off-by: Keith Packard <keithp@keithp.com> Reviewed-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7be4271d4..7a8fc5ba7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,6 +17,10 @@ if RECORD
RECORD_DIR=record
endif
+if DRI3
+DRI3_DIR=dri3
+endif
+
SUBDIRS = \
doc \
man \
@@ -38,6 +42,7 @@ SUBDIRS = \
damageext \
$(COMPOSITE_DIR) \
$(GLX_DIR) \
+ $(DRI3_DIR) \
exa \
config \
hw \