summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2014-02-18 00:57:24 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2014-02-21 22:47:51 +0000
commit9eae750317b52d05448ec327ec7499908a4653cf (patch)
treeafaa3a0f0f7c68cec6c5757f41e4eb21b98b8eeb /configure.ac
parentc2ebbe2728cd709029313f4b9c9cc53432c510a1 (diff)
configure: use default dri drivers whenever opengl and dri are enabled
Commit ee55500c22a(configure: cleanup classic dri drivers handling) cleaned up the logic handling autodetection of dri drivers, but missed the case when one can explicitly disable dri, and still request opengl. Fixes build issues for the following ./autogen.sh --disable-dri --with-gallium-drivers=swrast While we're here, explicitly clear with_dri_drivers whenever building without such drivers to prevent choking later on. v2: Simplify with_dri_drivers handling. Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=75126 Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 6 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 58ecd6cc182..ed7f6b7fb5e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -950,15 +950,13 @@ AC_ARG_WITH([dri-drivers],
[with_dri_drivers="$withval"],
[with_dri_drivers=auto])
-case "$with_dri_drivers" in
-no) ;;
-auto)
- # classic DRI drivers
- if test "x$enable_opengl" = xyes; then
+if test "x$with_dri_drivers" = xauto; then
+ if test "x$enable_opengl" = xyes -a "x$enable_dri" = xyes; then
with_dri_drivers="yes"
+ else
+ with_dri_drivers="no"
fi
- ;;
-esac
+fi
dnl If $with_dri_drivers is yes, drivers will be added through
dnl platform checks. Set DEFINES and LIB_DEPS
@@ -1039,7 +1037,7 @@ AC_SUBST([GALLIUM_DRI_LIB_DEPS])
DRI_DIRS=""
dnl Duplicates in DRI_DIRS are removed by sorting it after this block
-if test -n "$with_dri_drivers"; then
+if test "x$with_dri_drivers" != xno; then
if test "x$enable_opengl" != xyes; then
AC_MSG_ERROR([--with-dri-drivers requires OpenGL])
fi