summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2009-05-19 18:38:06 -0700
committerEric Anholt <eric@anholt.net>2009-05-19 18:38:06 -0700
commit5296fa767d819fa39e947ce2341cf8300e0aba3e (patch)
tree7502b95225e68e452fbff6655a7adc075ffa5c7d
parent1d97be6e10914654d5ea718d2e44f18ca161cc94 (diff)
Start filling in the debianization bits.
-rw-r--r--debian/control14
-rw-r--r--debian/copyright64
-rwxr-xr-xdebian/rules28
3 files changed, 68 insertions, 38 deletions
diff --git a/debian/control b/debian/control
index 2f121f6..db37238 100644
--- a/debian/control
+++ b/debian/control
@@ -1,13 +1,15 @@
Source: intel-gpu-tools
-Section: unknown
-Priority: extra
+Section: main
+Priority: optional
Maintainer: Eric Anholt <eric@anholt.net>
Build-Depends: debhelper (>= 7), autotools-dev
Standards-Version: 3.8.1
-Homepage: <insert the upstream URL, if relevant>
+Homepage: http://www.intellinuxgraphics.org/
Package: intel-gpu-tools
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Description: <insert up to 60 chars description>
- <insert long description, indented with spaces>
+Depends: libdrm-intel1 (>= 2.4.6), ${shlibs:Depends}, ${misc:Depends}
+Description: tools for debugging the Intel graphics driver
+ intel-gpu-tools is a package of tools for debugging the Intel graphics driver,
+ including a GPU hang dumping program, performance monitor, and performance
+ microbenchmarks for regression testing the DRM.
diff --git a/debian/copyright b/debian/copyright
index 40a74f1..234d0fb 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,28 +1,70 @@
This package was debianized by Eric Anholt <eric@anholt.net> on
-Tue, 19 May 2009 18:23:16 -0700.
+Tue, 19 May 2009 15:00:52 -0700.
-It was downloaded from <url://example.com>
+It was downloaded from http://xorg.freedesktop.org/archive/individual/app/
Upstream Author(s):
- <put author's name and email here>
- <likewise for another author>
+ Eric Anholt <eric@anholt.net>
+ Jesse Barnes <jbarnes@virtuousgeek.org>
+ Keith Whitwell <keith@tungstengraphics.com>
+ Carl Worth <cworth@cworth.org>
Copyright:
- <Copyright (C) YYYY Name OfAuthor>
- <likewise for another author>
+ Copyright © 2005 Adam Jackson
+ Copyright © 2007-2009 Intel Corporation
+ Copyright 1998-1999, 2006 Tungsten Graphics, Inc., Cedar Park, Texas.
License:
+The code is covered by the MIT license. Most of it is under the common form
+that just says "authors and copyright holders":
- <Put the license of the package here indented by 4 spaces>
+ Permission is hereby granted, free of charge, to any person obtaining a
+ copy of this software and associated documentation files (the "Software"),
+ to deal in the Software without restriction, including without limitation
+ the rights to use, copy, modify, merge, publish, distribute, sublicense,
+ and/or sell copies of the Software, and to permit persons to whom the
+ Software is furnished to do so, subject to the following conditions:
+
+ The above copyright notice and this permission notice (including the next
+ paragraph) shall be included in all copies or substantial portions of the
+ Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+ THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+ FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+ IN THE SOFTWARE.
+
+Some of the code is also under the MIT license but specifically mentions
+Tungsten Graphics:
+
+ Permission is hereby granted, free of charge, to any person obtaining a
+ copy of this software and associated documentation files (the
+ "Software"), to deal in the Software without restriction, including
+ without limitation the rights to use, copy, modify, merge, publish,
+ distribute, sub license, and/or sell copies of the Software, and to
+ permit persons to whom the Software is furnished to do so, subject to
+ the following conditions:
+
+ The above copyright notice and this permission notice (including the
+ next paragraph) shall be included in all copies or substantial portions
+ of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+ OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT.
+ IN NO EVENT SHALL PRECISION INSIGHT AND/OR ITS SUPPLIERS BE LIABLE FOR
+ ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+ TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
The Debian packaging is:
Copyright (C) 2009 Eric Anholt <eric@anholt.net>
-and is licensed under the GPL version 3,
+and is licensed under the GPL version 3,
see `/usr/share/common-licenses/GPL-3'.
-
-# Please also look if there are files or directories which have a
-# different copyright/license attached and list them here.
diff --git a/debian/rules b/debian/rules
index b73488a..67849ac 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,30 +36,29 @@ endif
build: build-stamp
-build-stamp: config.status
+build-stamp: config.status
dh_testdir
# Add here commands to compile the package.
$(MAKE)
- #docbook-to-man debian/intel-gpu-tools.sgml > intel-gpu-tools.1
touch $@
-clean:
+clean:
dh_testdir
dh_testroot
- rm -f build-stamp
+ rm -f build-stamp
# Add here commands to clean up after the build process.
[ ! -f Makefile ] || $(MAKE) distclean
rm -f config.sub config.guess
- dh_clean
+ dh_clean
install: build
dh_testdir
dh_testroot
- dh_prep
+ dh_prep
dh_installdirs
# Add here commands to install the package into debian/intel-gpu-tools.
@@ -74,27 +73,14 @@ binary-indep: install
binary-arch: install
dh_testdir
dh_testroot
- dh_installchangelogs
+ dh_installchangelogs
dh_installdocs
dh_installexamples
-# dh_install
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_python
-# dh_installinit
-# dh_installcron
-# dh_installinfo
dh_installman
dh_link
dh_strip
dh_compress
dh_fixperms
-# dh_perl
-# dh_makeshlibs
dh_installdeb
dh_shlibdeps
dh_gencontrol
@@ -102,4 +88,4 @@ binary-arch: install
dh_builddeb
binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+.PHONY: build clean binary-indep binary-arch binary install