summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2009-09-04 11:09:39 -0700
committerEric Anholt <eric@anholt.net>2009-09-04 11:09:39 -0700
commit0430f1ade77c090e55315d2bd52f7e4a8ef4ef0a (patch)
treeb143ab1325e941d570da9774ff1409ca0392fa41
parent7493a4eccc63555036d96f9c0c8098e294e4c34f (diff)
rules cleanups from jcristau's review.
-rwxr-xr-xdebian/rules24
1 files changed, 10 insertions, 14 deletions
diff --git a/debian/rules b/debian/rules
index 67849ac..6130d2e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,17 +20,20 @@ else
CROSS= --build $(DEB_BUILD_GNU_TYPE)
endif
+CFLAGS = -g -Wall
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O2
+else
+ CFLAGS += -O0
+endif
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ MAKEFLAGS += -j$(NUMJOBS)
+endif
config.status: configure
dh_testdir
- # Add here commands to configure the package.
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess config.guess
-endif
./configure $(CROSS) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
@@ -39,7 +42,6 @@ build: build-stamp
build-stamp: config.status
dh_testdir
- # Add here commands to compile the package.
$(MAKE)
touch $@
@@ -49,9 +51,7 @@ clean:
dh_testroot
rm -f build-stamp
- # Add here commands to clean up after the build process.
[ ! -f Makefile ] || $(MAKE) distclean
- rm -f config.sub config.guess
dh_clean
@@ -61,15 +61,11 @@ install: build
dh_prep
dh_installdirs
- # Add here commands to install the package into debian/intel-gpu-tools.
$(MAKE) DESTDIR=$(CURDIR)/debian/intel-gpu-tools install
-# Build architecture-independent files here.
binary-indep: install
-# We have nothing to do by default.
-# Build architecture-dependent files here.
binary-arch: install
dh_testdir
dh_testroot