summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulien Isorce <julien.isorce@gmail.com>2008-08-14 10:37:32 +0200
committerJulien Isorce <julien.isorce@gmail.com>2008-08-14 10:37:32 +0200
commita750ec80abfcf3280abe66d85a6b65407c088080 (patch)
treedae3fc7d92cae1c6cc51468b15e1a79166ba1d2c /configure.ac
parentf65675512d96b4c43eb04c85fc75b8ff820fde43 (diff)
add GLEW check in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index acf6ed5..7ef7fed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,12 +155,9 @@ then
AC_ERROR([liboil-0.3.8 or later is required])
fi
-dnl glew is required
-#PKG_CHECK_MODULES(GLEW, libglew1.5 >= 1.5.0, HAVE_GLEW=yes, HAVE_GLEW=no)
-#if test "x$HAVE_GLEW" != "xyes"
-#then
-# AC_ERROR([libglew1.5.0 or later is required])
-#fi
+dnl Check for GLEW/OpenGL
+AC_SEARCH_LIBS(glLoadIdentity, [GL opengl32], , AC_MSG_ERROR([Opengl not found make sure you have Opengl installed]))
+AC_SEARCH_LIBS(glewInit, [GLEW glew32], , AC_MSG_ERROR([Glew not found make sure you have GLEW installed]))
dnl checks for gstreamer
dnl uninstalled is selected preferentially -- see pkg-config(1)