summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2009-06-25 17:37:20 +0100
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2009-06-26 10:34:45 +0100
commitd1f37075cb7104cedb21fdcfa81ac807d881b4e9 (patch)
tree7c43a7955f599656e5dc0a296558a8b7d98d7dec /configure.ac
parentbcba747e07b1f425bbd505222e80a3f1d7902a97 (diff)
configure.ac: fix version
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index baec533..c423697 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,12 +13,12 @@ m4_define([wocky_micro_version], [0])
m4_define([wocky_nano_version], [0])
# Some magic
-m4_define([wockybase_version],
- [wockymajor_version.wockyminor_version.wockymicro_version])
-m4_define([wockyversion],
- [m4_if(wockynano_version, 0, [wockybase_version], [wockybase_version].[wockynano_version])])dnl
+m4_define([wocky_base_version],
+ [wocky_major_version.wocky_minor_version.wocky_micro_version])
+m4_define([wocky_version],
+ [m4_if(wocky_nano_version, 0, [wocky_base_version], [wocky_base_version].[wocky_nano_version])])dnl
-AC_INIT([Wocky], [wockyversion])
+AC_INIT([Wocky], [wocky_version])
AC_CONFIG_MACRO_DIR([m4])
@@ -33,7 +33,7 @@ AM_PROG_AS
AM_PROG_MKDIR_P
dnl decide error flags
-ifelse(wockynano_version, 0,
+ifelse(wocky_nano_version, 0,
[ official_release=yes ],
[ official_release=no ])
@@ -53,7 +53,7 @@ TP_COMPILER_WARNINGS([ERROR_CFLAGS], [test "x$official_release" = xno],
unused-parameter])
AC_SUBST([ERROR_CFLAGS])
-ifelse(wockynano_version, 0,
+ifelse(wocky_nano_version, 0,
[ # Wocky is version x.y.z - disable coding style checks by default
AC_ARG_ENABLE(coding-style-checks,
AC_HELP_STRING([--enable-coding-style-checks],