summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWill Thompson <will.thompson@collabora.co.uk>2010-03-22 15:37:29 +0000
committerMike Ruprecht <mike.ruprecht@collabora.co.uk>2010-05-30 12:57:42 -0500
commitaad3e48e1333bfe8659b2eb70c89081233856428 (patch)
tree583094b938b99f0bab9948ab7cb6fcc435d87bee /configure.ac
parent9cdcd094234ebfe40429d827c2ec2b6bb5d917a6 (diff)
Add a configure switch to install headers
Previously, Gabble hard-coded a list of Wocky headers to install if it was built with --enable-plugin-api. This is fragile in the face of the list of headers changing. With this patch, passing --with-installed-headers=/path/to/headers to Wocky's configure will cause `make install` to put headers there. I had to split BUILT_SOURCES and HANDWRITTEN_SOURCES into sources and headers, and lowercase them because FOO_HEADERS is magic in Automake. I took the liberty of sorting the lists while I was at it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 41f5976..12faed6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,6 +90,16 @@ if test "$enable" = yes; then
AC_DEFINE(ENABLE_DEBUG, [], [Enable debug code])
fi
+AC_ARG_WITH(installed-headers,
+ AC_HELP_STRING([--with-installed-headers=DIR],
+ [install development headers to DIR @<:@default=nowhere@:>@]),
+ [],
+ [with_installed_headers=])
+
+AM_CONDITIONAL(INSTALL_HEADERS, test x$with_installed_headers != x)
+
+HEADER_DIR=$with_installed_headers
+AC_SUBST(HEADER_DIR)
dnl Check for code generation tools
AC_HEADER_STDC([])