summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCosimo Cecchi <cosimo.cecchi@collabora.co.uk>2010-08-30 11:35:33 +0200
committerCosimo Cecchi <cosimo.cecchi@collabora.co.uk>2010-08-30 11:35:33 +0200
commit80a14a93939cf9125a91f4698bdc91a61ac67e19 (patch)
tree6fceae972acfb20c53583bdb53ce2e5f346dc95f /configure.ac
parentf049ff52818a36d1f69a79d045c6ab34b12b5807 (diff)
configure: always set the right value to $with_tls
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 49fe9c5..1e96baa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -128,10 +128,10 @@ AS_CASE([$with_tls],
AC_DEFINE(USING_OPENSSL, 1, [Define if using openssl])
PKG_CHECK_MODULES(TLS, [openssl >= 0.9.8g])],
[auto], [PKG_CHECK_MODULES(TLS, [gnutls >= 2.8.2 ],
- [],
+ [with_tls=gnutls],
[USING_OPENSSL=yes
AC_DEFINE(USING_OPENSSL, 1, [Define if using openssl])
- PKG_CHECK_MODULES(TLS, [openssl >= 0.9.8g],[],
+ PKG_CHECK_MODULES(TLS, [openssl >= 0.9.8g],[with_tls=openssl],
AC_MSG_ERROR([Neither gnutls nor openssl found]))])],
[*], AC_MSG_ERROR([Must have a TLS backend (gnutls or openssl)]))