summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMikhail Zabaluev <mikhail.zabaluev@nokia.com>2009-08-27 14:49:18 +0300
committerMikhail Zabaluev <mikhail.zabaluev@nokia.com>2009-08-27 14:49:18 +0300
commitf814765b59a2552b8d739956f5a7fdc8b2d3efd0 (patch)
treed8fb08db00f33878a4f0d8d353da18e6d953b706 /configure.ac
parent1f78e9c6cc27b66dd53d0402cd50979fb07b5893 (diff)
Use AM_PATH_PYTHON to check for Python
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 7d87d19..2bacddc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,11 +122,9 @@ AC_CHECK_PROGS([XSLTPROC], [xsltproc])
if test -z "$XSLTPROC"; then
AC_MSG_ERROR([xsltproc (from the libxslt source package) is required])
fi
-PYTHON=
-AC_CHECK_PROGS([PYTHON], [python2.7 python2.6 python2.5 python2.4 python2.3 python])
-if test -z "$PYTHON"; then
- AC_MSG_ERROR([Python is required to compile this package])
-fi
+AM_PATH_PYTHON([2.3],[],
+ [AC_MSG_ERROR([Python is required to compile this package])]
+)
dnl Check for twisted python for tests
AC_MSG_CHECKING([for TwistedPython with SIP protocol support])