summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHans de Goede <hdegoede@redhat.com>2012-01-10 10:24:49 +0100
committerHans de Goede <hdegoede@redhat.com>2012-01-10 13:26:58 +0100
commita1c0042dd602651cbc6ef5d2670f2ad5f46b17f4 (patch)
tree339a8cb9b924f8f5c1ee695548cdb0819bc999ee /configure.ac
parentde2bf74160782810b06f1ebd643f92638f42215b (diff)
Add a --enable-static-uinput option
This makes spice-vdagentd create the tablet uinput device once and then keep it around forever. This is necessary for X-servers without hotplug support, such as the RHEL-5 X-server. Signed-off-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b18e38d..93070b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,20 +24,31 @@ AC_ARG_ENABLE([pciaccess],
[enable_pciaccess="$enableval"],
[enable_pciaccess="yes"])
+AC_ARG_ENABLE([static-uinput],
+ [AS_HELP_STRING([--enable-statis-uinput], [Enable use of a fixed, static uinput device for X-servers without hotplug support (default: no)])],
+ [enable_static_uinput="$enableval"],
+ [enable_static_uinput="yes"])
+
PKG_PROG_PKG_CONFIG
PKG_CHECK_MODULES(X, [xfixes xrandr xinerama x11])
PKG_CHECK_MODULES(SPICE, [spice-protocol >= 0.8.0])
+
if test x"$enable_console_kit" = "xyes" ; then
PKG_CHECK_MODULES(DBUS, [dbus-1])
AC_DEFINE([HAVE_CONSOLE_KIT], [1], [If defined, vdagentd will be compiled with ConsoleKit support] )
fi
AM_CONDITIONAL(HAVE_CONSOLE_KIT, test x"$enable_console_kit" = "xyes")
+
if test x"$enable_pciaccess" = "xyes" ; then
PKG_CHECK_MODULES(PCIACCESS, [pciaccess >= 0.10])
AC_DEFINE([HAVE_PCIACCESS], [1], [If defined, vdagentd will be compiled with pciaccess support] )
fi
AM_CONDITIONAL(HAVE_PCIACCESS, test x"$enable_pciaccess" = "xyes")
+if test x"$enable_static_uinput" = "xyes" ; then
+ AC_DEFINE([WITH_STATIC_UINPUT], [1], [If defined, vdagentd will use a static uinput device] )
+fi
+
AC_CONFIG_FILES([
Makefile
])