summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2011-12-21 15:19:36 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2011-12-22 09:33:48 +0100
commitd103002c17ab362f14f3487c3299115f7b0be720 (patch)
tree1635b8d207601c318cb30bd005bbe104ad072752 /configure.ac
parent720d6622df49caa2fa31e5466f4548a472dc5334 (diff)
Make path to the USB ACL helper configurable
It's currently installed in $bindir, but this patch makes it possible for distros like fedora to install it in $libexecdir/spice/
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f0db9fa..771d5a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -348,6 +348,13 @@ else
fi
fi
+AC_ARG_WITH([usb-acl-helper-dir],
+ AS_HELP_STRING([--with-usb-acl-helper-dir=DIR],
+ [Directory where the USB ACL helper binary should be installed]),
+ [ACL_HELPER_DIR="$with_usb_acl_helper_dir"],
+ [ACL_HELPER_DIR="${bindir}/"])
+AC_SUBST([ACL_HELPER_DIR])
+
AC_ARG_WITH([coroutine],
AS_HELP_STRING([--with-coroutine=@<:@ucontext/gthread/winfiber/auto@:>@],
[use ucontext or GThread for coroutines @<:@default=auto@:>@]),