summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHans de Goede <hdegoede@redhat.com>2012-02-20 16:45:32 +0100
committerHans de Goede <hdegoede@redhat.com>2012-02-22 17:16:43 +0100
commit708d77a9ad51c659de0b5ef5a8225e8310f13499 (patch)
tree54acef43b990de49aa143f859650612d6972f986 /configure.ac
parentc64150541db0b8301f066901671bba1b7040599f (diff)
configure: Fix "USB redirection support" summary on --disable-usbredir
When running "./configure --disable-usbredir" the "USB redirection support" line in the summary at the end of ./configure would be empty after "support" instead of ending with yes or no. Signed-off-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7332b6d..bf9b4ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -343,7 +343,7 @@ AC_ARG_ENABLE([usbredir],
[enable_usbredir="auto"])
if test "x$enable_usbredir" = "xno"; then
- AM_CONDITIONAL(WITH_USBREDIR, false)
+ have_usbredir="no"
else
PKG_CHECK_MODULES([USBREDIR],
[gudev-1.0 libusb-1.0 >= 1.0.9 libusbredirhost >= 0.3.4 libusbredirparser >= 0.3.4],
@@ -355,8 +355,8 @@ else
if test "x$have_usbredir" = "xyes"; then
AC_DEFINE(USE_USBREDIR, [1], [Define if supporting usbredir proxying])
fi
- AM_CONDITIONAL([WITH_USBREDIR], [test "x$have_usbredir" = "xyes"])
fi
+AM_CONDITIONAL([WITH_USBREDIR], [test "x$have_usbredir" = "xyes"])
AC_ARG_ENABLE([polkit],
AS_HELP_STRING([--enable-polkit=@<:@auto/yes/no@:>@],