summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ea58dae659..336429ae99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -621,6 +621,11 @@ AC_ARG_ENABLE([gallium_gbm],
@<:@default=auto@:>@])],
[enable_gallium_gbm="$enableval"],
[enable_gallium_gbm=auto])
+AC_ARG_ENABLE([remote],
+ [AS_HELP_STRING([--enable-remote],
+ [enable remoting libGL @<:@default=auto@:>@])],
+ [enable_remote="$enableval"],
+ [enable_remote=no])
# Option for Gallium drivers
GALLIUM_DRIVERS_DEFAULT="r300,r600,swrast"
@@ -801,6 +806,19 @@ x*yes*)
;;
esac
+case "x$enable_remote$enable_glx$enable_xlib_glx" in
+xyesnono|xyesnoyes|xyesyesyes)
+ echo "--enable-remote requires --enable-glx and no --enable-xlib-glx"
+ exit 1
+ ;;
+xyesyesno)
+ GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/remote-xlib"
+ GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS libgl-xlib-remote"
+ GALLIUM_STATE_TRACKERS_DIRS="glx $GALLIUM_STATE_TRACKERS_DIRS"
+ HAVE_WINSYS_XLIB="yes"
+ ;;
+esac
+
case "x$enable_glx$enable_xlib_glx" in
xyesyes)
DRIVER_DIRS="$DRIVER_DIRS x11"