summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Green <andy@warmcat.com>2011-01-20 10:23:50 +0000
committerAndy Green <andy@warmcat.com>2011-01-20 10:23:50 +0000
commited11a02201b53a6f72d60efcaa5ef726e4ece9ec (patch)
tree5f4b5f54c7a41f70d603317bf3d9248c1e56fe00 /configure.ac
parente92cd1764ee0d5110fa8a587810446631a9ea702 (diff)
add-enable-nofork-config-option.patch
Signed-off-by: Andy Green <andy@warmcat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d3a407b..2ccdd68 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,17 @@ AC_CHECK_LIB([ssl], [SSL_library_init])
CFLAGS="$CFLAGS -DLWS_OPENSSL_SUPPORT"
fi
+AC_ARG_ENABLE(nofork,
+ [ --enable-nofork Disables fork-related options],
+ [ nofork=yes
+ ])
+
+if test "x$nofork" = "xyes" ; then
+CFLAGS="$CFLAGS -DLWS_NO_FORK"
+else
+AC_FUNC_FORK
+fi
+
# Checks for header files.
@@ -37,7 +48,7 @@ AC_CHECK_HEADERS([fcntl.h netinet/in.h stdlib.h string.h sys/socket.h unistd.h])
AC_TYPE_SIZE_T
# Checks for library functions.
-AC_FUNC_FORK
+
AC_FUNC_MALLOC
AC_FUNC_REALLOC
AC_CHECK_FUNCS([bzero memset socket strerror])