summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2010-09-01 11:17:03 +0300
committerAlon Levy <alevy@redhat.com>2010-09-01 11:17:03 +0300
commit682d17691b8e3a2c78957743e9324cf9b3e7a524 (patch)
treebd3a6d81ab895e183f3eb7a6d2c23db5777ba9e0 /Makefile.am
parentfe1b9435bab66cbad8426d6bc20585aa96c3f532 (diff)
Makefile converted to autoconf based configure.ac and automake Makefile.am
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am79
1 files changed, 79 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..5f6f4e9
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,79 @@
+NULL =
+
+INCLUDES= \
+ -I. \
+ $(NSS_CFLAGS) \
+ $(NULL)
+
+lib_LTLIBRARIES = libcac_card.la
+
+libcac_card_la_LIBADD = \
+ $(NSS_LIBS) \
+ $(NULL)
+
+
+libcac_card_la_SOURCES= \
+ cac.c \
+ card_7816.c \
+ event.c \
+ vcard_emul_nss.c \
+ vcard_emul_type.c \
+ vcard.c \
+ vreader.c \
+ $(NULL)
+
+libcac_cardincludedir = $(includedir)/cac_card
+
+libcac_cardinclude_HEADERS = \
+ vcard.h \
+ vcardt.h \
+ card_7816.h \
+ card_7816t.h \
+ vreader.h \
+ vreadert.h \
+ vevent.h \
+ eventt.h \
+ vcard_emul.h \
+ vcard_emul_type.h \
+ vscard_common.h \
+ $(NULL)
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = cac_card.pc
+
+#OBJS = ${SOURCES:.c=.o}
+
+bin_PROGRAMS = vscclient
+
+vscclient_SOURCES = \
+ vscclient.c \
+ $(NULL)
+
+vscclient_LDADD = \
+ -lcac_card \
+ $(NULL)
+
+doclean:
+ rm -f $(OBJS) link_test __htest.c __test.o vscclient
+
+#
+# Test targets....
+#
+
+# make sure our includes are self supporting
+header_test:
+ @for i in $(INCLUDE) ; do \
+ echo "#include \"$$i\"" > __htest.c ;\
+ echo "#include \"$$i\"" >> __htest.c ;\
+ cat __htest.c ; \
+ cc -c __htest.c ;\
+ done
+ @rm __htest.c __htest.o
+
+# make sure we don't have any missing symbols
+link_test: link_test.c $(OBJS)
+ cc -o link_test link_test.c $(OBJS) $(LDFLAGS)
+
+# Do all the tests at once
+tests: all link_test header_test
+