summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorrrelyea <rrelyea@fba4d07e-fe0f-4d7f-8147-e0026e666dc0>2006-11-30 22:35:28 +0000
committerrrelyea <rrelyea@fba4d07e-fe0f-4d7f-8147-e0026e666dc0>2006-11-30 22:35:28 +0000
commit78093de42d6edbc4ef0ff9ce2c2b5b33ec3130da (patch)
treef57c971f8561207d1238f7d001de7b991d4b5ca3 /configure.in
parent61e1011c5fe010d4dc7c009a9c1d076f02d2df62 (diff)
Fix compile problem with log.h
Make pk11install and optionally built feature. git-svn-id: http://svn.fedorahosted.org/svn/coolkey/trunk@35 fba4d07e-fe0f-4d7f-8147-e0026e666dc0
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 79b1c1b..364a075 100644
--- a/configure.in
+++ b/configure.in
@@ -82,6 +82,21 @@ case "$host" in
;;
esac
+# Add argument for pk11install
+AC_ARG_ENABLE(pk11install,
+ [ --enable-pk11install build an installer for legacy user apps(default=no)])
+if test "$enable_pk11install" = "yes" -o "$enable_pk11install" = "true"
+then
+if test $WINDOWS -ne 1; then
+ PKG_CHECK_MODULES(NSS, nss, true, [ AC_MSG_ERROR(could not find NSS Crypto libraries) ])
+fi
+ enable_pk11install = "yes"
+else
+ enable_pk11install = "no"
+ AC_MSG_WARN([skipping pk11install])
+fi
+
+
# Checks for programs.
AC_PROG_CC
AC_PROG_CXX
@@ -93,7 +108,6 @@ AC_PROG_LN_S
if test $WINDOWS -ne 1; then
AC_CHECK_LIB(z, uncompress, , AC_MSG_ERROR(could not locate libz compression library))
AC_CHECK_LIB(dl, dlopen, , AC_MSG_ERROR(could not locate dynamic library services library))
-PKG_CHECK_MODULES(NSS, nss, true, [ AC_MSG_ERROR(could not find NSS Crypto libraries) ])
fi
# add our compiled static libraries
@@ -122,6 +136,7 @@ AC_SUBST(PCSC_CFLAGS)
AC_SUBST(PCSC_LIBS)
AC_SUBST(SCARD_LIB_NAME)
AM_CONDITIONAL(HAVE_PCSC, test x$with_pcsclite = xyes)
+AM_CONDITIONAL(BUILD_PK11INSTALL, test x$enable_pk11install = xyes)
AC_DEFINE(DEBUG, 1, [Define to 1 if you want to include debugging code.])
# Checks for header files.