summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2012-07-25 14:51:09 +0100
committerKristian Høgsberg <krh@bitplanet.net>2012-07-25 10:40:11 -0400
commitea40bf88bce04fb212cc946d8e006d2731a5d944 (patch)
treec63877ac6e23f38c4c2cc33d06b50e39a9e51649 /configure.ac
parente302b3ef77894cb9fd4113c873a5502efc9a8dd6 (diff)
tests: Use pkg-config to find setbacklight CFLAGS and libs
setbacklight depends on udev and drm, one cannot just add the -l flags if you want to support unusual install paths.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c35d987..a8fc7f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -224,6 +224,7 @@ fi
AC_CHECK_PROG(RSVG_CONVERT, rsvg-convert, rsvg-convert)
AM_CONDITIONAL(HAVE_RSVG_CONVERT, test -n "$RSVG_CONVERT")
+PKG_CHECK_MODULES(SETBACKLIGHT, [libudev libdrm])
if test "x$GCC" = "xyes"; then
my_common_gcc_flags="-Wall -Wextra -Wno-unused-parameter \