summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2012-10-29 13:06:02 -0400
committerKristian Høgsberg <krh@bitplanet.net>2012-10-29 13:44:33 -0400
commitb98905e8104429857b74948d3cce658edc615f4a (patch)
tree80833509222127d2fe2f83cc8132278a775f5953 /configure.ac
parent16b41e442ba42824f7b7bca2208efa8e0572492e (diff)
configure.ac: Check for libGLU for screensaver
https://bugs.freedesktop.org/show_bug.cgi?id=56376
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0f34a7e..552c050 100644
--- a/configure.ac
+++ b/configure.ac
@@ -206,6 +206,10 @@ if test x$enable_weston_launch == xyes; then
WESTON_LAUNCH_LIBS="$WESTON_LAUNCH_LIBS -lpam"
fi
+PKG_CHECK_MODULES(GLU, [glu], [have_glu=yes], [have_glu=no])
+AM_CONDITIONAL(HAVE_GLU, test "x$have_glu" = "xyes")
+
+
AM_CONDITIONAL(HAVE_POPPLER, test "x$have_poppler" = "xyes")
AM_CONDITIONAL(BUILD_FULL_GL_CLIENTS,