summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-08-12 19:10:04 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2012-08-12 19:10:04 +0100
commit95b7f4fe3a5deea6766538d843c75626e4bb68cf (patch)
treefddfa0863d53deb39a28e1972b499cf47c70eabc /configure.ac
parent16426dab486767cb16dfaf5158c5d4b3317546b0 (diff)
image: Temporarily resurrect the old non-pixman glyph compositor
As the easiest approach to making another snapshot that only depends upon a stable pixman, make the new dependency a compile time option. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a721cdfe..0067bfc9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -619,7 +619,7 @@ CAIRO_ENABLE(test_surfaces, test surfaces, no)
dnl ===========================================================================
CAIRO_ENABLE_SURFACE_BACKEND(image, image, always, [
- pixman_REQUIRES="pixman-1 >= 0.27.1"
+ pixman_REQUIRES="pixman-1 >= 0.26.0"
PKG_CHECK_MODULES(pixman, $pixman_REQUIRES, , [AC_MSG_RESULT(no)
use_image="no (requires $pixman_REQUIRES http://cairographics.org/releases/)"])
image_REQUIRES=$pixman_REQUIRES
@@ -627,6 +627,11 @@ CAIRO_ENABLE_SURFACE_BACKEND(image, image, always, [
image_LIBS=$pixman_LIBS
])
+if pkg-config --exists 'pixman-1 >= 0.27.1'; then
+ AC_DEFINE([HAS_PIXMAN_GLYPHS], 1, [Enable pixman glyph cache])
+fi
+
+
dnl ===========================================================================
CAIRO_ENABLE_SURFACE_BACKEND(mime, mime, always)