summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2007-04-19 23:12:09 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2007-04-19 23:12:09 +0100
commitd64ef355217db7a555da0029187d19c80ec12609 (patch)
tree55f1eba8aa2d5c80f200f508b9aafdd5b92b404a /Makefile.am
parent0ffb021e9b0cc2ec9afc3eaa360b4518327afa6c (diff)
Include cairo-perf in make check
Although cairo-perf is not written to perform explicit failure testing of cairo, it does generate long sequences of cairo operations which often trigger unexpected errors. By including it with make check, it becomes even easier for the programmer to check that one has not broken cairo in terms of expected behaviour or performance.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 23166ea0..3d8e3603 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@ DIST_SUBDIRS = pixman src boilerplate test perf doc
SUBDIRS = pixman src doc
# libpng is required for our test programs
if CAIRO_HAS_PNG_FUNCTIONS
-SUBDIRS += boilerplate test
+SUBDIRS += boilerplate test perf
endif
@@ -19,6 +19,7 @@ recheck: all
cd test && $(MAKE) $(AM_MAKEFLAGS) recheck
check-valgrind: all
cd test && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
+ cd perf && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
perf: all
cd perf && $(MAKE) $(AM_MAKEFLAGS) perf
lcov: check