summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2007-04-20 01:28:56 -0400
committerBehdad Esfahbod <behdad@behdad.org>2007-04-20 01:28:56 -0400
commitd00aa44206f474e11c66c585d09bfd55e747cc5b (patch)
treebddf754d5df2dfe46cd9fd7ecb028698816c8e88 /Makefile.am
parent2a038956635e27f61fb2147527d2262eebf9bb26 (diff)
[Makefile.am] Add a "make snapshot" target
that creates a tarball named with version, date, and git hash of the tree. Like cairo-1.4.5-20070420-2a0389.tar.gz.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3d8e3603..518369b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,9 +70,18 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-test-surfaces
include $(srcdir)/ChangeLog.mk
# Some custom targets to make it easier to release things.
-# Use either:
+#
+# To make real stable releases or devel snapshots, use either:
# make release-check
# or make release-publish
+#
+# To make a quick properly named (date and git hash stamped) tarball:
+# make snapshot
+
+snapshot:
+ distdir="$(distdir)-`date '+%Y%m%d'`"; \
+ test -d "$(srcdir)/.git" && distdir=$$distdir-`cd "$(srcdir)" && git-rev-parse HEAD | cut -c 1-6`; \
+ $(MAKE) $(AM_MAKEFLAGS) distdir="$$distdir" dist
RELEASE_OR_SNAPSHOT = $$(if test "x$(CAIRO_VERSION_MINOR)" = "x$$(echo "$(CAIRO_VERSION_MINOR)/2*2" | bc)" ; then echo release; else echo snapshot; fi)
RELEASE_UPLOAD_HOST = cairographics.org