summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2008-01-16 23:21:53 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2008-01-16 23:21:53 +0000
commitbb41fa22e3d3b1fe4b3e802ecf7d8041eacda3fd (patch)
tree90e340d8781361e30e13cd59ded08d2bb3c705b2 /Makefile.am
parent0a4ced5a2659b168fe8d1a6e3917f79fd5c66ae5 (diff)
[Makefile.am] Further massage lcov paths for srcdir != builddir.
The lcov scripts generate incorrect absolute paths to the builddir for source files - so convert them to srcdir using sed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f1dbef01..1c217849 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,8 +35,8 @@ lcov-perf:
# we have to massage the lcov.info file slightly to hide the effect of libtool
# placing the objects files in the .libs/ directory separate from the *.c
genlcov:
- $(LTP) --directory $(top_builddir) --capture --output-file cairo-lcov.info --test-name CAIRO_PERF --no-checksum
- $(SED) -e 's#.libs/##' < cairo-lcov.info > cairo-lcov.info.tmp
+ $(LTP) --directory $(top_builddir) --path $(top_builddir) --capture --output-file cairo-lcov.info --test-name CAIRO_TEST --no-checksum
+ $(SED) -e 's#.libs/##' -e 's#$(shell pwd)#$(shell cd $(top_srcdir) && pwd)#' < cairo-lcov.info > cairo-lcov.info.tmp
LANG=C $(LTP_GENHTML) --prefix $(top_builddir) --output-directory cairo-lcov --title "Cairo Code Coverage" --show-details cairo-lcov.info.tmp
$(RM) cairo-lcov.info.tmp
else