summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2007-04-04 10:13:13 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2007-04-04 10:13:13 +0100
commit5c24711ee65cdb8ac0fdb7419e6466e2b7cb7d9e (patch)
tree11335e2f3d8e3c31b190792b18306cc3f319301e /Makefile.am
parent59e5189818321c8a62ad107548facbcfce9e517a (diff)
Restore gcov functionality
Add -lgcov to the shared library else the test programs fail to link. Add a couple of lcov convenience targets to generate the coverage reports.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 37693cf6..23166ea0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,6 +21,17 @@ check-valgrind: all
cd test && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
perf: all
cd perf && $(MAKE) $(AM_MAKEFLAGS) perf
+lcov: check
+ $(LTP) --directory $(top_builddir) --capture --output-file cairo-lcov.info --test-name CAIRO_TEST --no-checksum
+ LANG=C $(LTP_GENHTML) --prefix $(top_builddir) --output-directory cairo-test-lcov --title "Cairo Test Code Coverage" --show-details cairo-test-lcov.info
+lcov-perf: perf
+ $(LTP) --directory $(top_builddir) --capture --output-file cairo-perf-lcov.info --test-name CAIRO_PERF --no-checksum
+ LANG=C $(LTP_GENHTML) --prefix $(top_builddir) --output-directory cairo-perf-lcov --title "Cairo Perf Code Coverage" --show-details cairo-perf-lcov.info
+lcov-clean:
+ $(LTP) --directory $(top_builddir) --reset
+ $(RM) -rf \
+ cairo-test-lcov.info cairo-test-lcov \
+ cairo-perf-lcov.info cairo-perf-lcov
EXTRA_DIST = \
AUTHORS \
@@ -195,4 +206,4 @@ doc-publish: doc
scp $(MANUAL_TAR_FILE) $(RELEASE_UPLOAD_HOST):$(MANUAL_UPLOAD_DIR)
ssh $(RELEASE_UPLOAD_HOST) "cd $(MANUAL_UPLOAD_DIR) && tar xzf $(MANUAL_TAR_FILE) && rm -f manual && ln -s $(MANUAL_DATED) manual && ln -sf $(MANUAL_TAR_FILE) cairo-manual.tar.gz"
-.PHONY: release-verify-even-micro release-verify-newer release-remove-old release-cleanup-group-sticky release-check release-upload release-publish docs-publish
+.PHONY: release-verify-even-micro release-verify-newer release-remove-old release-cleanup-group-sticky release-check release-upload release-publish docs-publish lcov lcov-perf lcov-clean