summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2007-10-09 23:17:42 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2007-10-10 14:56:52 +0100
commit0b65c301a72836f46cdcda8b8fa1e995100c7727 (patch)
tree125f847cf38796e3aa8e978ac49f4d43146f188f /Makefile.am
parentb8d7d62b08576364c8c402490b6f5e4a1472d5d8 (diff)
[Makefile.am] Change lcov-clean to use more portable constructs.
Replace xargs and rm with the binaries found by configure and drop the passing of NUL-terminated strings as that is a GNU extension.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 6dd6d949..a47920f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,9 +41,9 @@ genlcov:
rm -f cairo-lcov.info.tmp
lcov-clean:
- $(LTP) --directory $(top_builddir) -z
- $(RM) -rf cairo-lcov.info cairo-lcov
- $(FIND) -name '*.gcda' -print0 | xargs -0 rm
+ -$(LTP) --directory $(top_builddir) -z
+ -$(RM) -rf cairo-lcov.info cairo-lcov
+ -$(FIND) -name '*.gcda' -print | ${XARGS} ${RM}
EXTRA_DIST = \
AUTHORS \